SULDR Forums Supported Printers Printing Questions Scanning Questions General Questions Samsung Installer

Author Topic: suld-driver-common-1 and suld-ppd-1 packages missing?  (Read 2066 times)

c0reDump

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Mint 17.2
  • Printer: Xpress C1860FW
Hello all, I have the Xpress C1860FW and would like to use the scanner with Linux Mint 17.2 x64.  I don't know if one of the suld drivers would help me or not, however I can't get them installed due to the following error.

I'm quite familiar with Linux, but this one has got me stumped.  Any ideas?

# apt-get install suld-driver-4.01.17
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 suld-driver-4.01.17 : Depends: suld-driver-common-1 but it is not installable
                       Depends: suld-ppd-2 but it is not installable
E: Unable to correct problems, you have held broken packages.

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: suld-driver-common-1 and suld-ppd-1 packages missing?
« Reply #1 on: May 15, 2016, 18:17:25 »
Try an apt-get update.  Some new packages have recently been added, and so the information on  your system may be out of date.

If that doesn't work, it may be due to the an authentication problem related to the new suldr-keyring package.  Try installing that first, then the driver.

c0reDump

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Mint 17.2
  • Printer: Xpress C1860FW
Re: suld-driver-common-1 and suld-ppd-1 packages missing?
« Reply #2 on: May 15, 2016, 18:50:18 »
Hi bchemnet -- everything is up to date and suldr-keyring was installed already.  This has got me stumped too...

# apt-get install suldr-keyring
Reading package lists... Done
Building dependency tree       
Reading state information... Done
suldr-keyring is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: suld-driver-common-1 and suld-ppd-1 packages missing?
« Reply #3 on: May 15, 2016, 18:56:00 »
When I have seen something like this before, and it isn't a cache issue, then it has been a dependency problem.  For some reason apt almost never indicates what the actual missing package is unless the dependency chain is very short.

Can you install suld-driver-common-1 and suld-ppd-2 individually?  If yes, then try suld-network-2, then suld-driver-4.01.17.  Only the driver package itself has several dependencies, so I bet the others will install, and then maybe you will get an accurate error for the driver.

c0reDump

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Mint 17.2
  • Printer: Xpress C1860FW
Re: suld-driver-common-1 and suld-ppd-1 packages missing?
« Reply #4 on: May 15, 2016, 19:06:04 »
Yeah, tried that -- from my perspective, it is not finding those packages at all.  Running:
   # apt search suld
I do not see that common or ppd packages listed at all (just the configurator, driver, driver2, and network packages are shown).

It is as if the package(s) are missing in the repo.

# apt-get install suld-driver-common-1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package suld-driver-common-1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'suld-driver-common-1' has no installation candidate

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: suld-driver-common-1 and suld-ppd-1 packages missing?
« Reply #5 on: May 15, 2016, 19:17:08 »
It sounds like you are missing all the "architecure:all" packages.  I don't know how one could even create such a situation, because I don't know of any way to exclude those.  And that doesn't make sense given that the keyring package installed, but I don't see any other common feature.  I certainly can't reproduce the problem you are having on my system.

What happens if you download the common or ppd package directly from http://www.bchemnet.com/suldr/pool/debian/extra/su/ and then use dpkg -i to install those?

c0reDump

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Mint 17.2
  • Printer: Xpress C1860FW
Re: suld-driver-common-1 and suld-ppd-1 packages missing?
« Reply #6 on: May 15, 2016, 19:30:26 »
# dpkg --print-architecture
amd64

# dpkg --print-foreign-architectures
i386

# dpkg --add-architecture all
dpkg: error: architecture 'all' is reserved and cannot be added

I have no idea what is screwed up with this system, but hadn't noticed problems with 'all' before...  Anyhow, manually installing those two packages via the deb (on your link, thanks!) went smoothly.

Finally, apt was able to get the driver installed.

Many Thanks!

# apt-get install suld-driver-4.01.17
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  suld-network-2
The following NEW packages will be installed:
  suld-driver-4.01.17 suld-network-2
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,495 kB of archives.
After this operation, 4,071 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://www.bchemnet.com/suldr/ debian/extra suld-network-2 amd64 4.01.17-1 [222 kB]
Get:2 http://www.bchemnet.com/suldr/ debian/extra suld-driver-4.01.17 amd64 4.01.17-3 [1,273 kB]
Fetched 1,495 kB in 1s (1,332 kB/s)           
Selecting previously unselected package suld-network-2.
(Reading database ... 190030 files and directories currently installed.)
Preparing to unpack .../suld-network-2_4.01.17-1_amd64.deb ...
Unpacking suld-network-2 (4.01.17-1) ...
Selecting previously unselected package suld-driver-4.01.17.
Preparing to unpack .../suld-driver-4.01.17_4.01.17-3_amd64.deb ...
Unpacking suld-driver-4.01.17 (4.01.17-3) ...
Setting up suld-network-2 (4.01.17-1) ...
Setting up suld-driver-4.01.17 (4.01.17-3) ...

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: suld-driver-common-1 and suld-ppd-1 packages missing?
« Reply #7 on: May 15, 2016, 19:54:01 »
Glad to help, hopefully you won't run into this again.

bchemnet

  • Administrator
  • *****
  • Posts: 524
    • View Profile
  • Linux Distribution: Debian Testing
  • Printer: none
Re: suld-driver-common-1 and suld-ppd-1 packages missing?
« Reply #8 on: May 16, 2016, 20:59:48 »
Can you try to refresh your repository now and let me know if you see the previously missing packages?

It appears that issue is a recent, undocumented change in the way apt-ftparchive creates repository files.  Previously "all" had both been its own section and duplicated within the other architectures.  Now it is only doing one or the other, depending on the configuration, and only one method generates files that work with older apt versions.

c0reDump

  • Splashing around
  • ***
  • Posts: 6
    • View Profile
  • Linux Distribution: Mint 17.2
  • Printer: Xpress C1860FW
Re: suld-driver-common-1 and suld-ppd-1 packages missing?
« Reply #9 on: May 17, 2016, 17:18:29 »
Hi bchemnet:
   # apt search suld
now returns the common and ppd packages.  Seems like you fixed it from my end.  Thanks again.

 

Repository Information Legal Contact Alternative Drivers